informatique:linux:apt-erreur-les-signatures-suivantes-ne-sont-pas-valables

apt erreur : les signatures suivantes ne sont pas valables

apt, correction de l'erreur signatures non valables

En executant la commande apt update, l'erreur suivante est apparue :

Les signatures suivantes ne sont pas valables : EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key <deb@sury.org>
...
Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

La clé de sécruité du serveur distant a changé et le programme apt bloque les informations car elles ne sont plus conformes. Il faut mettre à jour votre clé suivant celle qui est présente sur le serveur.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B188E2B695BD4743

La valeur B188E2B695BD4743 correspond à la clé qui pose problème, affichée dans le message d'alerte du programme apt.

Entrer votre commentaire. La syntaxe wiki est autorisée:
Si vous ne pouvez pas lire les caractères sur l'image, téléchargez ce fichier .wav pour l'écouter.
 
  • informatique/linux/apt-erreur-les-signatures-suivantes-ne-sont-pas-valables.txt
  • Dernière modification: 2022/01/09 12:55
  • de Cédric ABONNEL